Помогите написать программу вычисления в Pascal.
Var x:real; begin Read(x); if x < -6 then begin Writeln('No Solution'); halt; end; x:= sqrt(2*x + 12); Writeln('y = ', sqrt(1 + abs(2 + x))/3,28); end.