Написать программу которая находит сумму десяти чисел , введённых пользователем с...

0 голосов
83 просмотров

Написать программу которая находит сумму десяти чисел , введённых пользователем с клавиатуры.


Информатика (36 баллов) | 83 просмотров
0

Можешь пример дать?

0

Просто не могу понять, как найти сумму слов

0

Если расскажешь, как найти сумму слов, то алгоритм напишу

0

Алгоритм на каком языке? На аглоритмическом, на Pascal, на Basic... ?

0

опечатка : чисел

Дано ответов: 2
0 голосов

Алгоритм на Pascal


program abc;var sum,i,k:longint; begin for i:=1 to 10 do begin read(k); sum:=sum+k; end; writeln(sum); end.

(229 баллов)
0

program abc;
var
sum,i,k:longint;
begin
for i:=1 to 10 do begin
read(k);
sum:=sum+k;
end;
writeln(sum);
end.

0

Скопируйте нормально в ответ.. что в ответе - не работает, а комменты не считаются

0

Программу требуют в виде блок-схем

0

Сайт делает так, что строки которые я копировал, соединяются в 1

0

Не сайт, а лишь некоторые браузеры. Нужно исправить

0

я могу сказать только одно, ответ нельзя редактировать))

0

Обновите страницу - можно будет.

0 голосов
program summation;
var num, sum, counter, userValue : integer;

begin

writeln('Сколько раз просуммировать числа?');
 
readln(userValue);

for counter := 1 to userValue do

begin
    sum := 0;
    repeat
    writeln('Введите число: ');
    readln(num);

if num >= 0 then
         sum := num + sum; 
          until num < 0;
 writeln('Сумма чисел равна: ', sum);
    readln;  
end;

end.
(586 баллов)