СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!! написать программу ** паскале которая...

0 голосов
25 просмотров
СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!!
написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше.

Информатика (47 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Эта прога может работать не только с 4-ех значными числами
Она на Pascal.


var a,last_num,first_num:integer;

begin
Write('Введите число');
read(a);
last_num:=a mod 10;
first_num:=a;
while first_num>10 do
begin
first_num:= first_num div 10;
end;
writeln('Последняя цифра ', last_num, ', Первая цифра ', first_num);
if first_num > last_num then
writeln('Первая цифра больше')
else if first_num = last_num then
writeln('Они равны')
else if last_num > first_num then
writeln('Последняя цифра больше');
end.

(248 баллов)