Написать программу для подсчёта количества вхождений подстроки в строку. (Язык С++)

0 голосов
58 просмотров

Написать программу для подсчёта количества вхождений подстроки в строку. (Язык С++)


Информатика (1.8k баллов) | 58 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;
int main()
{
    string str, substr;
    cout << "String = "; getline(cin, str);<br>    cout << "Substring = "; cin >> substr;
    int cnt = 0;
    for(int i = 0; i < str.length(); ++i)
        if(str[i] == substr[0])
            if(str.substr(i, substr.length()) == substr)
            {
                ++cnt;
                i += substr.length() - 1;
            }
    cout << cnt;<br>    return 0;
}

/****************************************************/
Пример:
String = test testHelloWorld testtest1243test
Substring = test
5

(9.4k баллов)