Написать программу для подсчёта суммы цифр чисел, записанных в файл. (Язык С++)

0 голосов
27 просмотров

Написать программу для подсчёта суммы цифр чисел, записанных в файл. (Язык С++)


Информатика (1.8k баллов) | 27 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
#include
using namespace std;

int main() {
  int n;
  float s=0;
  ifstream f;
  f.open("input.txt");
  while(!f.eof()) {
     f>>n;
     while (n>0) { s+=n%10; n=n/10; }
  }   
  f.close();
  cout<<s<<endl;<br>  system("pause");
  return 0;
}

(9.7k баллов)