Помогите написать программу ** c++

0 голосов
13 просмотров

Помогите написать программу на c++


image

Информатика (5.5k баллов) | 13 просмотров
0

че за единица над k?

0

а блин 1/k :)

0

Если вы хотите, чтобы вам кто-нибудь ответил, пишите понятней. Лично я не очень-то понимаю вашу запись.

Дан 1 ответ
0 голосов
Правильный ответ

#include

using namespace std;

int main() {
    double sum = 0;
    double k = 1;
    cout << fixed;<br>    cout.precision(10);
    for (k = 2; k <= 7; k++)<br>        sum = sum + (1/k);
    k = 1;
    for (int i = 1; i <= 5; i++) <br>        k = k * sum;
    cout << k << endl;<br>    system("pause");
    return 0;
}


Так сделано:
\sum\limits_{k=2}^7 \frac{1}{k} = \frac{223}{140}
\prod\limits_{i=1}^5 \frac{223}{140} = 10.25378334442.....

(9.4k баллов)
0

Спасибо большое за решение! Но можете пожалуйста обьяснить что за строка и зачем она нужна?) cout.precision(10);

0

А вся, она вроде нужна для отображение 10 элементов в ответе :D

0

Можно убрать строчки:

0

//cout << fixed;<br> //cout.precision(10);
//cout << k << endl;

0

И написать: printf("%f5\n", k);

0

printf("%.5f\n", k); точнее.