Напишите программу поиска все двузначных чисел, в которых есть цифра n, или само число...

0 голосов
35 просмотров

Напишите программу поиска все двузначных чисел, в которых есть цифра n, или само число делится на n (решите по паскалю).


Информатика (2.9k баллов) | 35 просмотров
Дано ответов: 2
0 голосов
var
  i, n: integer;
begin
  readln(n);
  for i := 10 to 99 do
    if (i mod 10 = n) or (i div 10 = n) or (i mod n = 0) then write(i:4);
end.
(1.4k баллов)
0 голосов

Var
  i,n: integer;
begin
  readln(n);
  for i:= 10 to 99 do
    if (i mod 10 = n) or (i div 10 = n) or (i mod n = 0) then writeln(i)
end.

(598 баллов)