Написать программу в паскале. Входные данные : вводятся 4 числа, а, b, C, d Выходные...

0 голосов
129 просмотров

Написать программу в паскале. Входные данные : вводятся 4 числа, а, b, C, d
Выходные данные : найдите все целые решения уравнения ax^3+bx^2+cx+d=0 на отрезке [0,1000] и выведите их в порядке возрастания. Если на данном отрезке нет ни одного решения, то ничего выводить не нужно.


Информатика | 129 просмотров
0

a,b,c,d - целые?

0

Но вообще за 5 баллов такую задачу выставлять...

0

Спасибо

0

Я сейчас попробую написать..

0

Не думаю, что разберетесь, если сейчас не можете определиться.

0

Ещё бы знать что это такое......... Можешь тупо написать прогу,там разберусь

0

Либо тупой перебор 1001^4 вариантов, либо нахождение корней полинома по Горнеру...

0

Целые

Дан 1 ответ
0 голосов
//PascalABC.NET
//Версия 3.3, сборка 1611 (06.01.2018)

begin
  var (a,b):=ReadInteger2('Введите a,b,c,d->');
  var (c,d):=ReadInteger2;
  Write('Корни: ');
  for var x:=0 to 1000 do
   if a*x**3+b*x**2+c*x+d=0 then Write(x,' ');
end.

Пример:
Введите a,b,c,d-> 1 -3 -13 15
Корни: 1 5 

(5.8k баллов)
0

Пхпх ну раз на то пошло то в тг?

0

*Рэцдколл

0

Месседжеры - это скайп, вайбер, вотсап, рэйдкодд, тимспик и им подобное

0

Он только зовётся месседжером...

0

Телеграмм?

0

Это мессенджер

0

тг - тоже соцсеть, если что

0

Умные не сидят в соцсетях, откуда сливают их персональные данные. )))

0

Мб в вк поговорим? Интересно общаться с умными

0

*RaidCall