Pascal Составить программу, которая считывает целое число. Если оно четное и...

0 голосов
64 просмотров

Pascal
Составить программу, которая считывает целое число. Если оно четное и положительное, увеличить его в два раза, в противном случае увеличить в 10 раз


Информатика (35 баллов) | 64 просмотров
Дан 1 ответ
0 голосов

Program p1;
var x: integer;
begin
    writeln('введите число');
    readln(x);
    if (x mod 2 = 0) and (x > 0) then
        x:=x*2
    else
        x:=x*10;
    writeln(x);
end.


(887 баллов)