Написать программу,которая запросит у пользователя два числа и одине из знаков : + - * /...

0 голосов
98 просмотров

Написать программу,которая запросит у пользователя два числа и одине из знаков : + - * / и выведет на экран результат соответствующего арифметического действия. Помогите пожалуйста.СРОЧНО


Информатика (66 баллов) | 98 просмотров
Дано ответов: 2
0 голосов

Program z1;
var a,b:real;
c:char;
begin
read(a,b,c);
if c='+' then writeln(a+b) else
if c='-' then writeln(a-b) else
if c='*' then writeln(a*b) else
if c='/' then writeln(a/b) else
writeln('символ не арифметического действия');
end.

(1.3k баллов)
0

Спасибо) А что значит ('символ не арифметического действия')&

0

Это означает, если ты вводишь не один из этих знаков : + - / *, то символ не арифметического действия

0

спасибо

0 голосов

Program ABC;var A,B,C:real;D:char;beginwrite ('Введите знак операции ');read (D);write ('Введите два числа ');read (A,B);case D of'+' : C:=A+B;'-' : C:=A-B;'*' : C:=A*B;'/' : C:=A/B;end;writeln (C);end.

(68 баллов)
0

пссс, во первых снова привет, во вторых делай всегда с энтером, людям не удобно вот так видеть прогу

0

Я понял, я затупил, написал нерез shift+enter

0

да,не особо удобно разбираться,но все равно спасибо