Паскаль. Написать программу проверка знаний таблицы умножения. Программа должна вывести...

0 голосов
116 просмотров

Паскаль. Написать программу проверка знаний таблицы умножения. Программа должна вывести 10 примеров и выставить процент знаний ученика: 100% отлично, 90%-80 % хорошо, 70%-40% удовлетворительно, 30%-0% Неудовлетворительно. С встроенной процедурой CRT


Информатика (18 баллов) | 116 просмотров
Дан 1 ответ
0 голосов

Uses crt;var  k, i, a, b, c: byte;
begin   clrscr;   randomize;   for i := 1 to 10 do  begin    a := random(1, 10);    b := random(1, 10);    write(a, ' * ', b, ' = ');    read(c);    if a * b = c then inc(k);  end;  case k of    0..3: writeln(k, '0% Неудовлетворительно');    4..7: writeln(k, '0% Удовлетворительно');    8..9: writeln(k, '0% Хорошо');    10: writeln(k, '0% Отлично');  end;end.

(489 баллов)
0

uses crt;
var
k, i, a, b, c: byte;

begin
clrscr;
randomize;
for i := 1 to 10 do
begin
a := random(1, 10);
b := random(1, 10);
write(a, ' * ', b, ' = ');
read(c);
if a * b = c then inc(k);
end;
case k of
0: writeln(k, '% Неудовлетворительно');
1..3: writeln(k, '0% Неудовлетворительно');
4..7: writeln(k, '0% Удовлетворительно');
8..9: writeln(k, '0% Хорошо');
10: writeln(k, '0% Отлично');
end;
end.

0

Так лучше