Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна...

0 голосов
48 просмотров

Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной площадке


Информатика (97 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program P1;
var z,x,y,p,e:integer;
begin
  write('Количество этажей = '); readln(x);
  write('Количество квартир на лестничной площадке = ');
  readln(y);
  write('Номер квартиры = '); readln(z);
  p:=(z-1) div (x*y)+1;
  e:=((z-(p-1)*x*y)-1) div y +1;
  writeln('Квартира ',z,' находится в ',p,' подъезде на ',e,' этаже');
end.

Пример:
Количество этажей = 9
Количество квартир на лестничной площадке = 4
Номер квартиры = 67
Квартира 67 находится в 2 подъезде на 8 этаже

(194k баллов)