Помогите, пожалуйста, 20 баллов
нужно написать программу на данную задачу в Паскале:
Найти сумму всех чисел вводимых пользователем от -20 до 20.
вот начало программы:
var a,s: integer;
begin
read(a);
s:0;
while a>0 do
begin
S:=S+a
read(a);
end;
write(S);
end.
нужно доделать и записать комментарии к программе