ЛЕГКО НО МЕНЯ НЕ БЫЛО ** УРОКЕ ПОМОГИТЕ Написать программу: С клавиатуры вводиться число...

0 голосов
41 просмотров

ЛЕГКО НО МЕНЯ НЕ БЫЛО НА УРОКЕ ПОМОГИТЕ Написать программу: С клавиатуры вводиться число N. Заполнить массив N случайными числами. В массиве может находиться не более 100 элементов. Упорядочить массив по возрастанию и сформировать новый массив, каждый элемент которого равен исходному плюс полученному элементу.


Информатика (158 баллов) | 41 просмотров
0

Сказали одноклассники

0

Если вам что-то не нравится пройдите мимо

Дан 1 ответ
0 голосов

Program massiv;
var M: array [1..100] of integer;
M2: array [1..100] of integer;
a,n,i,i2 : integer;
begin
read (n);
for i:= 1 to n do begin
readln (a);
M[i]:=a;
M2[i]:=a;
end;
for i:= 1 to n do begin
for i2:= i+1 to n do begin
if (M[i]< M[i2]) then begin
a:=M[i2];
M[i2]:=M[i];
M[i]:=a;
end;end;end;
for i:=1 to n do begin
M[i]:= M[i]+M2[i];  
writeln(M[i]);
end;end.

(130 баллов)
0

Это точно правильно?

0

Программа-то работает правильно, вопрос в другом, правильно ли вы смогли объяснить, что именно она должна делать.