Задача ** c++ Напишите программу, которая находит все различные цифры в символьной...

0 голосов
169 просмотров

Задача на c++
Напишите программу, которая находит все различные цифры в символьной строке.

Формат входных данных

На вход программе подаётся символьная строка.

Формат выходных данных

Программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. Если в строке нет цифр, нужно вывести слово 'NO'.


Информатика (280 баллов) | 169 просмотров
Дан 1 ответ
0 голосов

// Если захочешь перенести массив из глобальных переменных, не забудь обнулить его

#include

using namespace std;

bool a[10];
int main()
{
  string s;
  cin >> s;
  for (int i = 0 ; i < s.length(); ++i)
    if (isdigit(s[i]))
        {
          int ind = s[i]-'0';
          a[ind] = true;
        }
  bool fl = false;
  for (int i = 0; i < 10; ++i)
    if (a[i])
      {
        fl = true;
        cout << i << ' ';<br>      }
if (!fl)
        cout << "NO";<br>
}



(8.8k баллов)