Помогите написать программу ** C++

0 голосов
18 просмотров

Помогите написать программу на C++


image

Информатика (5.5k баллов) | 18 просмотров
0

Непечатаемые символы надо выводить как-нибудь?

0

так выведет все символы, но часть из них не отобразится: for(int i=0;i<256;i++) cout<<(char)i<

0

Ага.

0

Наверное нет, раз в условии ничего не сказано :D

Дан 1 ответ
0 голосов

//Обычный вывод
#include
using namespace std;
int main(){

    for(int i = 0; i < 256; i++)
            cout << i << " = " << char(i) << endl;              <br>    system("pause");
    return 0;
}



//Вывод с непечатаемыми символами
#include
using namespace std;
int main(){
const char *mas[] = {
"NUL", "SOH","STX",    "ETX","EOT", "ENQ", "ACK", "BEL",
"BS", "HT", "LF", "VT", "FF", "CR", "SO", "SI",
"DLE", "DC1", "DC2", "DC3", "DC4", "NAK", "SYN",
"ETB", "CAN", "EM", "SUB", "ESC", "FS", "GS", "RS", "US", "SPACE"};

    for(int i = 0; i < 256; i++)
        if (i == 127) cout << i << " = " << "DEL" << endl;<br>        else
        {
        if (i < 33)
            cout << i << " = " << mas[i] << endl;<br>        else
            cout << i << " = " << char(i) << endl;  <br>        }
    system("pause");
    return 0;
}

(9.4k баллов)