Написать программу ** языке Pascal для решения следующей задачи: Дан массив 4x4 из целых...

0 голосов
66 просмотров

Написать программу на языке Pascal для решения следующей задачи: Дан массив 4x4 из целых чисел. Вычислить в массиве количество элементов равных пяти, имеющих чётные индексы строки. Ввод массива, вычисление количества оформить в виде подпрограмм.


Информатика (35 баллов) | 66 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

function MatRead:array[,] of integer;
begin
  Writeln('Вводите элементы через пробел построчно');
  Result:=ReadMatrInteger(4,4)
end;

function PartCount(a:array[,] of integer):=
    a.ElementsWithIndexes.Where(t->(t[0]=5) and t[1].IsOdd).Count;

begin
  var a:=MatRead;
  Writeln('*** Исходный массив ***');
  a.Println(6); Writeln(6*a.ColCount*'-');
  Writeln('Искомых элементов: ',PartCount(a))
end.

Пример
Вводите элементы через пробел построчно
34 12 21 5 0 3 12 5 -6 18 5 16 5 -15 16 7
*** Исходный массив ***
    34    12    21     5
     0     3    12     5
    -6    18     5    16
     5   -15    16     7
------------------------
Искомых элементов: 2
(150k баллов)
0

А существует упрощенное решение?