Составить программу, которая заполняет массив, сортирует по убыванию, находит максимум м...

0 голосов
43 просмотров

Составить программу, которая заполняет массив, сортирует по убыванию, находит максимум м выводит его до и после сортировки.


Информатика (54 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  a:=a.OrderByDescending(t->t).ToArray; a.Println;
  Writeln('Максимум: ',a.First);
end.

Пример
n= 15
22 26 18 -12 44 44 44 50 -30 11 6 8 -22 2 25
50 44 44 44 26 25 22 18 11 8 6 2 -12 -22 -30
Максимум: 50
(150k баллов)