Нужно написать программу ** паскаль Срочно! Нужно сделать треугольник вот такой ---1---...

0 голосов
21 просмотров

Нужно написать программу на паскаль Срочно!
Нужно сделать треугольник вот такой
---1---
--121--
-12321-
1234231 и тд


Информатика (56 баллов) | 21 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=4;
var i,j:integer;
begin
for i:=1 to n do
 begin
 for j:=1 to n-i do write('-');
 for j:=1 to i do write(j);
 for j:=i-1 downto 1 do write(j);
 for j:=1 to n-i do write('-');
 writeln;
 end;
end.

Результат:
---1---
--121--
-12321-
1234321

(194k баллов)
0

Спасибо )

0

Пожалуйста.