Очень срочно нужно решить задачку ** мове PascalABC Вычислить количество цифр целого...

0 голосов
46 просмотров

Очень срочно нужно решить задачку на мове PascalABC


Вычислить количество цифр целого неотрицательного числа n.
Входные данные #1
12343
Выходные данные #1
5


Информатика (23 баллов) | 46 просмотров
Дано ответов: 2
0 голосов

Что-то типа этого, PascalABC.NET
begin
var a:=ReadInteger().ToString();
write(a.Count());
end.

(4.2k баллов)
0

В отличие от языков семейства С, пустые скобки при отсутствии параметров не нужны. Т.е. они не ошибка, а просто лишние))

0 голосов

Var
  n,k:integer;
    
begin
  Write('n ='); Read(n);
  n:=Abs(n); { от злобных буратинок с отрицательными числами }
  if k=n then k:=1
  else begin
    k:=0;
    while n>0 do begin
      k:=k+1;
      n:=n div 10
      end
    end;
  Writeln('Количество цифр в числе равно ',k)
end.

Пример
n =435342134
Количество цифр в числе равно 9

(142k баллов)