Python!!! Напишите программу, которая находит в массиве количество элементов, равных...

0 голосов
573 просмотров

Python!!!
Напишите программу, которая находит в массиве количество элементов, равных максимальному.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести два числа, разделив их пробелом: максимальный элемент массива и количество элементов массива, равных максимальному.

Примеры
входные данные
6
1 2 3 2 3 3
выходные данные
3 3


Информатика (48 баллов) | 573 просмотров
Дан 1 ответ
0 голосов

N=int(input('задайте размер массива  '));
lst=input().split(' ');
mx=0; 
for i in range (0,n):
    if (int(lst[i])>mx):
        mx=int(lst[i]);
        k=1;
    else:
        if (int(lst[i])==mx): 
            k+=1;
print(mx,k);

задайте размер массива  10
-15 10 14 7 21 19 13 21 11 17
21 2

(9.7k баллов)