Помогите пожалуйста написать эту программу с while! Напишите программу, ко­то­рая в...

0 голосов
43 просмотров

Помогите пожалуйста написать эту программу с while!
Напишите программу, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет ко­ли­че­ство чисел, крат­ных 3. Про­грам­ма по­лу­ча­ет на вход ко­ли­че­ство чисел в последовательности, а затем сами числа. В по­сле­до­ва­тель­но­сти все­гда име­ет­ся число, крат­ное 3. Ко­ли­че­ство чисел не пре­вы­ша­ет 100. Введённые числа не пре­вы­ша­ют 300. Про­грам­ма долж­на вы­ве­сти одно число — ко­ли­че­ство чисел, крат­ных 3.


Информатика (93 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,k,m,p: integer;
begin
  write('n = ');  readln(n);
  k:=0; p:=0;
  while k  begin
    read(m);
    if m mod 3 = 0 then p:=p+1;
    k:=k+1;
  end;
  writeln('количество чисел, кратных 3: ',p);
end.

n = 6
10 -13 14 -15 21 23
количество чисел, кратных 3: 2

(9.7k баллов)
0

Можно спросить ,а что такое p?

0

p - это переменная для подсчета количества чисел, делящихся на 3.