Составьте программу на языке паскаль
и так, вопрос по Паскалю, сие не найти в интернете (ну по крайней мере мне)
вопрос:
Как оператор case заключить в case. Самое главное чтобы можно было сделать программу которая могла работать так:
»выберите раздел
»1-физика
»2-геометрия
»3-алгебра
1
»вы выбрали физику
»выберите действие
»1-узнать скорость
»2-узнать путь
1
»введите время пути в часах
И так далее там.
Если нужен пример кода то вот, но он не рабочий:
var
v,g,a,f:char;
time:real;
lenght:real;
speed:real;
begin
writeln('Выберите раздел:');
writeln('1-физика');
writeln('2-геометрия');
writeln('3-алгебра');
writeln('Ваш выбор: '); readln(v);
case v of
'1' begin
writeln('Выберите действие');
writeln('1-узнать скорость');
writeln('2-узнать путь');
write('Ваш выбор: '); readln(f);
case f of
'1': begin
writeln('Введите время пути в часах');
readln(time);
writeln('Введите длину пути в киллометрах ');
readln(lenght);
speed:=lenght/time;
writeln('Скорость=', speed:5:1,'км/ч')
end;
'2': begin
writeln('Введите скорость движения в км/ч');
readln(speed);
writeln('Введите время пути в часах');
readln(time);
lenght:=speed*time;
writeln('Путь=', lenght:5:1,'км');
end else writeln('Ощибка, такого пункта нет!');
end;
end;
end.