Помогите пожалуйста,напишите программу c while. Напишите программу для решения следующей...

0 голосов
215 просмотров

Помогите пожалуйста,напишите программу c while.
Напишите программу для решения следующей задачи . Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведи YES, иначе выведите NO. Программа получает на вход число проехавших автомобилей N ( 1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести максимальную скорость, затем YES или NO.


Информатика (93 баллов) | 215 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var sp: real;
    n,k,m,mn,mx: integer;
begin
  mx:=0; mn:=300;
  readln(n);
  k:=0;
  while k  begin
    read(sp);
    m:=round(sp);
    if m<30 then mn:=30;<br>    if m>mx then mx:=m;
    k:=k+1;
  end;
  write(mx);
  if mn=30 then writeln('  YES')
  else writeln('   NO');
end.

8
43.2 29.3 48.6 78.54 62 71 93.15 110
110  YES

5
45 55.6 78.9 30 87.6
88   NO

(9.7k баллов)