составить программу решения уравнения АХ=В)) срочно)) помогите)

0 голосов
86 просмотров

составить программу решения уравнения АХ=В)) срочно)) помогите)


Информатика (12 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Видимо уравнение все же имеет вид A*x*x + B*x + C = 0
//решение на C
#include
#include
#include

int main()
{
float A, B, C, D;
float res, res1, res2;

scanf("%f%f%f", &A, &B, &C);
D = B*B - 4*A*C;
if(D<0.f) printf("уравнение не имеет вещественных корней");<br>if(D==0.f)
{
float res = -B/(2.f*A);
printf("res = %f", res);
}
if(D>0.f)
{
float res1 = (-B-sqrt(D))/(2.f*A);
float res2 = (-B+sqrt(D))/(2.f*A);
printf("res1 = %f\nres2 = ", res1, res2);
}
return 0;
}

(4.0k баллов)