Ребят, помогите решить задачу по информатике) Нужно написать программу ** паскале. Тема:...

0 голосов
24 просмотров

Ребят, помогите решить задачу по информатике) Нужно написать программу на паскале. Тема: циклы
Вот условие)
Как известно, национальным овощем жителей сказочной страны Мурландии является картофель. Новое руководство озабочено тем, чтобы был сформированы запасы этого ценнейшего продукта на зиму. В этом году был хороший урожай Картофеля и N домов со всей Мурландии внесли свою лепту в общее хранилище. Поставлен план получить не менее K тонн. Из каждого дома этой сказочной страны сдали по Аi тонн картофеля. Можно ли получить K или более тонн картофеля и выполнить план?
Входные данные:
В первой строке входного файла натуральные числа N и K, в последующих N строках содержатся количество тонн картофеля из каждого дома.

Ограничения: N, K, Ai - натуральные числа, не превосходящие 20 000.
Выходные данные:
В единственную строку выходного файла вывести Yes в случае ответа "Да", No в противном случае.


Информатика (38 баллов) | 24 просмотров
0

Как входной файл называется?

0

и как называется выходной файл

Дан 1 ответ
0 голосов

Var
tmp,s,i,k,n:integer;
f,w:text;
begin
Assign(f,'input.txt');reset(f);
Assign(w,'output.txt');rewrite(w);
Readln(f,n,k);
for i:= 1 to n do
  begin
  readln(f,tmp);
  s:=s+tmp;
end;
if s >=k then Writeln(w,'Yes')
  else Writeln(w,'No');
  close(f);close(w);
end.

(8.8k баллов)