Даю 30 балов помогите с информатикой. надо написать программу в Паскаль АВС.

0 голосов
13 просмотров

Даю 30 балов помогите с информатикой. надо написать программу в Паскаль АВС.


image

Информатика (165 баллов) | 13 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b:real;
begin
readln(a);
if (a>=0)or(a>100) then b:=sqrt(a) // (a>100) здесь лишнее!
else b:=abs(a);
writeln(b:5:2);
end.

Пример:
20
4.47

(194k баллов)
0

if (a>=0)or(a>100) then b:=sqrt(a) // (a>100) здесь лишнее!

0

как это понять ? что здесь лишнее

0

обьясни

0

Число которое больше 100 не может быть отрицательным

0 голосов

Var a,res: double;
begin
   a := 100;       
if a>100  then res := sqrt(a)   
else res:=abs(a);       
writeln(res:5:2)   
end.

(6.5k баллов)