Написать программу ** с++. Помогите. Заранее спасибо!

0 голосов
18 просмотров

Написать программу на с++. Помогите. Заранее спасибо!


image

Информатика (15.4k баллов) | 18 просмотров
Дан 1 ответ
0 голосов

#include
#include

using namespace std;

int main()
{
    int N;
    int array[100];
    ifstream file1 ("input.txt");
    ofstream file2 ("output.txt");
    file1 >> N;
    for(int i = 0;i < N;i++)  {
        file1 >> array[i];
        if(i % 2 == 0)
            file2 << array[i] << " ";<br>    }

    return 0;
}

(3.7k баллов)
0

#include
#include
#include
using namespace std;

int main(){
int N;
int array[10];
ifstream cin("input.txt");
ofstream cout("output.txt");
cin >> N;
for(int i = 0;i < N;i++) {
cin >> array[i];
if(i % 2 == 0)
cout << array[i] << " "; <br> }

return 0;
}

0

В этом решении нужно что-то доработать , в программе оно не работает

0

Сейчас исправлю

0

работает?