Составить программу решения линейного уравнения ax + b = 0, где а не равно 0.

0 голосов
47 просмотров

Составить программу решения линейного уравнения ax + b = 0, где а не равно 0.


Информатика (15 баллов) | 47 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('a,b=');
  Writeln('x = ',-b/a)
end.

Пример
a,b= -15 2.18
x = 0.145333333333333
(150k баллов)