Напишите программу для нахождения НОК для n чисел (Pascal)

0 голосов
47 просмотров

Напишите программу для нахождения НОК для n чисел (Pascal)


Информатика (177 баллов) | 47 просмотров
Дан 1 ответ
0 голосов
1 2 3 4 5 6 7 8 9 10 11 12 uses crt; var a,b,c:integer;   begin  readln(a,b);  c:=a*b;  repeat   if a>b then a:=a-b else b:=b-a;  until a=b  c:=с div a;  writeln(c); end;P.S. Использовано свойство НОД(a,b)*НОК(a,b)=a*b
(98 баллов)