Напишите программу [** Pascal], которая вычисляет минимальное из трёх введённых чисел....

0 голосов
190 просмотров

Напишите программу [на Pascal], которая вычисляет минимальное из трёх введённых чисел. Используйте функцию.


Информатика (19 баллов) | 190 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
function min(x,y:integer):integer;
begin
if xend;
var a,b,c:integer;
begin
readln(a,b,c);
writeln('min = ',min(min(a,b),c));
end.

Пример:
8 2 5
min = 2
(194k баллов)
0 голосов
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function Min3(a,b,c:real):=Min(a,Min(b,c));

begin
  var (x,y,z):=ReadReal3('Введите три числа:');
  Writeln('Минимальное: ',Min3(x,y,z))
end.

Пример
Введите три числа: 3.18 -2 5.7
Минимальное: -2
(150k баллов)