Помогите написать программу. ** языке С++ Тема была классы в C++ Задание и пример...

0 голосов
17 просмотров

Помогите написать программу. На языке С++
Тема была классы в C++
Задание и пример программы во вложении.
Нужно по примеру сделать задание.


image
image

Информатика (63 баллов) | 17 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// ConsoleApplication4.cpp: определяет точку входа для консольного приложения.
//
#include "stdafx.h"
#include
#include
using namespace std;
class stud {
public:
void setname(string sname)
{
name = sname;
}
string getname()
{
return name;
}
string getsurname()
{
return surname;
}
void setsurname(string ssurname)
{
surname = ssurname;
}
void setscore(int sc[])
{
for (int i = 0; i<10; i++) score[i] = sc[i];<br>}
float getsr()
{
float sum = 0;
for (int i = 0; i<10; i++) sum += (float)score[i];<br>return sum / 10;
}
void showmyself()
{
cout << "Студент: " << name << " " << surname << endl;<br>cout << "Имеет 10 текущих оценок: ";<br>for (int i = 0; i < 10; i++) cout << score[i] << " ";<br>cout << "" << endl;<br>cout << "Его средний балл: " << getsr() << endl;<br>}
private:
string name;
string surname;
int score[10];
};
int main(int acgc, char* argv[])
{
setlocale(LC_ALL, "rus");
stud student1;
int score[10];
string name, surname;
cout << "Введите имя студента: "<<endl;<br>getline(cin, name);
cout << "Введите фамилию студента: " << endl;<br>getline(cin, surname);
cout << "введите 10 текущих оценок через пробел: " << endl;<br>for (int i = 0; i<10; i++) cin >> score[i];
student1.setname(name);
student1.setsurname(surname);
student1.setscore(score);
student1.showmyself();
system("pause");
}


image
(149k баллов)
0

сбилось форматирование, сейчас исправлю

0

готово