☺КАРОЧ ТАК!! эт дело должно выполнятся по ПРОГРАММЕ ( 9 КЛАСС ПРОГРАММИРОВАНИЕ )ДАЮ 100...

0 голосов
77 просмотров
КАРОЧ ТАК!! эт дело должно выполнятся по ПРОГРАММЕ ( 9 КЛАСС ПРОГРАММИРОВАНИЕ )ДАЮ 100 Баллов!♥Надеюсь на помощь*
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., Портфеля стоимостью В руб., и Галстука стоимостью D руб., ВСЕ ИСХОДНЫЕ ДАННЫЙ ЗАДАЮТСЯ С КЛАВИАТУРЫ.


Информатика (102 баллов) | 77 просмотров
0

Только ты даешь не 100 а 50. 100 на двоих :)

0

ну да да))

Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c,d,e,f: Integer;
Begin
Write('Введите начальную сумму денег: '); Read(c);
Write('Введите стоимость перчаток: '); Read(a);
Write('Введите стоимость портфеля: '); Read(b);
Write('Введите стоимость галстука: '); Read(d);
e := a + b + d;
f := c - e;
Writeln('Вы потратили: ', e, ' рублей');
Writeln('У Вас осталось: ', f, ' рублей');
End.

(14.4k баллов)
0

Ну а если ввели меньше? Надо предусмотреть все варианты.

0

Или можно с 1 рублем и купить машину и дом?)

0

В задаче сказано: Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., Портфеля стоимостью В руб., и Галстука стоимостью D руб. То есть после покупки 3 вещей, а он их ТОЧНО купил, отрицательного ответа не может быть. Если бы задание сформулировано было по другому, возможны варианты, я над этим думал, но если попросили "покороче", зачем лезть в "дебри".

0

Я думаю, мнение учителя будет другое. Им бы только найти к чему прицепится.
А Write('Введите стоимость перчаток: '); Read(a); - это не короче. можно и всю программу написать в 1 строке, но от этого она короче не станет.

0

Я написал Ксении что Ваш вариант правильный и рабочий.

0

И? Да мне всё равно :) Просто я говорю как есть. Ибо был уже случай, просила не очень заумно, а в итоге на следующий день начала претензии ставить, что препод ругал :)

0

Тут уже зависит от учителя. Ответ получен? Получен. Это можно даже устно сосчитать :)

0

Я в 2-3 раза сложнее задания за 5 пкт делал..) Это вообще халява. Но походу автор другого мнения :)

0

Я тоже не совсем понял, за что тут можно давать 50 пкт =)

0

В любом случае, и мой вариант решения и Ваш - верный. Кто будет смотреть пусть выбирают :)

0 голосов

Program Task;
Var A, B, C, D, E: Integer;
Begin
WriteLn('Сколько рублей было у человека?');
ReadLn(C);
WriteLn('Сколько стоили перчатки?');
ReadLn(A);
WriteLn('Сколько стоил портфель?');
ReadLn(B);
WriteLn('Сколько стоил галстук?');
ReadLn(D);
E := C - (A + B + D);
If E > 0 Then
WriteLn('У человека осталось', E, ' рублей')
Else If E = 0 Then
WriteLn('У человека не осталось денег')
Else
WriteLn('У человека не хватило денег');
ReadLn;
End.

(2.8k баллов)
0

а по кароче

0

пожалуйста по кароче)