СРОЧНО !!!!! Написать программу которая выводит ** экран сумму 5 натуральных чисел....

0 голосов
38 просмотров

СРОЧНО !!!!!
Написать программу которая выводит на экран сумму 5 натуральных чисел. Смотреть задание используя 3 циклические конструкции


image

Информатика (34 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Var
  i,n,s:integer;
 
begin
  Write('Введите 5 натуральных чисел: ');
  s:=0;
  for i:=1 to 5 do begin
    Read(n);
    s:=s+n
    end;
  Writeln('for: ',s);
  Write('Введите 5 натуральных чисел: ');
  s:=0; i:=1;
  while i<=5 do begin<br>    Read(n);
    s:=s+n;
    i:=i+1
    end;
  Writeln('while: ',s);
  Write('Введите 5 натуральных чисел: ');
  s:=0; i:=1;
  repeat
    Read(n);
    s:=s+n;
    i:=i+1
  until i>5;
  Writeln('repeat: ',s)
end.

Пример
Введите 5 натуральных чисел: 5 8 12 6 2
for: 33
Введите 5 натуральных чисел: 5 12 8 2 6
while: 33
Введите 5 натуральных чисел: 12 8 5 6 2
repeat: 33

(142k баллов)
0

Тут можно вводить любые натуральные числа, не превышающие в сумме 2 147 483 647