1.Напишите программу для решения следующей задачи: Дано целое число. Является ли оно...

0 голосов
35 просмотров

1.Напишите программу для решения следующей задачи:
Дано целое число. Является ли оно четным?
2.Составьте программу вычисления у по задачному х.


image

Информатика (12 баллов) | 35 просмотров
0

Помогите пожалуйста!!!СРОЧНО!!!!!!!!

Дан 1 ответ
0 голосов

1.

var
a: integer;
begin
writeln('Введите число');
readln(a);
if a mod 2=0 then writeln('Чётное') else writeln('Нечётное');
 end.


2.
 

var
x:integer;
y:real;
begin
y:=0;
writeln('Введите x: ');
readln(x);
if (x>0) then y:= x;
if (x < 0) or (x = 0) then y:= 1/x;
writeln('y = ', y);
end.  

(1.8k баллов)