Помогите с Паскалем. Нужно написать программу которая выводит наибольшую цифру в...

0 голосов
38 просмотров

Помогите с Паскалем. Нужно написать программу которая выводит наибольшую цифру в введенном числе.


Информатика (29 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (n,dmax):=(Abs(ReadInteger('n=')),0);
  while n>0 do begin
    var t:=n mod 10;
    if t>dmax then dmax:=t;
    n:=n div 10
    end;
  Writeln(dmax)
end.

Пример
n= 2450234
5
(150k баллов)