Напишите программы ** Паскале, используя цикл "Пока". 1)Составьте алгоритм вычисления...

0 голосов
53 просмотров

Напишите программы на Паскале, используя цикл "Пока".
1)Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.
2)Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.


Информатика (36 баллов) | 53 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
Program n1;
var sum,n,i: integer;
begin
i:=1;
sum:=0;
readln(n);
while i<=n do<br>begin
sum:=sum+i;
i:=i+1;
end;
write(sum);
end.

2)
Program n2;
var x,n,i,z: integer;
p: integer;
begin
readln(x,n);
i:=0;
p:=1;
z:=1;
if x<0 then z:=-1;<br>x:=abs(x);
while i<>n do
begin
p:=p*x;
i:=i+1;
end;
if (z=-1) and (i mod 2=0) then write(p) else if (z=-1) and (i mod 2<>0) then write(-p) else write(p);
end.

(150k баллов)