Помогите написать программу ** pascal для решения задачи. Использовать циклы. Я в 9-ом...

0 голосов
20 просмотров

Помогите написать программу на pascal для решения задачи.
Использовать циклы. Я в 9-ом классе.


image

Информатика (12 баллов) | 20 просмотров
Дан 1 ответ
0 голосов

Var
a:array[1..100] of integer;
i,n,k,s:integer;
begin
write('Введите количество членов последовательности: ');
readln(n);
a[1]:=1;
a[2]:=1;
s:=0;
for i:=3 to n do 
a[i]:=a[i-2]+a[i-1];
write('Последовательность Фибоначчи: ');
for i:=1 to n do begin
s:=s+a[i];
write(a[i], ' ');
end;
writeln;
write('Введите искомый член последовательности: ');
readln(k);
for i:=3 to k do 
a[i]:=a[i-2]+a[i-1];
writeln(k, '-й член последовательности: ',a[i], ' ');
writeln('Сумма ',n,' первых членов последовательности: ',s);
end.

(7.8k баллов)