Напишите программу, которая вводит натуральное число N и выводит ** экран чётные...

0 голосов
144 просмотров

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем 2 N , в порядке убывания.


Информатика (31 баллов) | 144 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

program HelloWorld;

 

var N: integer;

var i,ii: integer;

var y: real;

 

begin

    writeln('Введите значение N:');

    readln(N);

   

    for i:=N downto 2 do

     if i mod 2 = 0 then

     begin

         y := 2;

         for ii:=1 to i-1 do

           y := y*2;        

         writeln(y:10:0);

     end;

end.

(6.5k баллов)