Составить блок схему и написать программу которая находит сумму цифр четного...

0 голосов
132 просмотров

Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа либо произведение нечетного четырехзначного числа


Информатика (118 баллов) | 132 просмотров
Дан 1 ответ
0 голосов

Программа:
program abc;
var x,s,p:integer;
begin
writeln('Введите четырехзначное число');
readln(x);
if (x mod 2)=0 then
begin
  s:=(x mod 10)+(x div 10 mod 10)+(x div 100 mod 10)+x div 1000;
  writeln('s=',s);
  end
else
  begin
  p:=(x mod 10)*(x div 10 mod 10)*(x div 100 mod 10)*x div 1000;
  writeln('p=',p);
  end;
end.
Блок-схема



image
(130 баллов)