Помогите составить программу ** PascalABC.net задание 9.4

0 голосов
27 просмотров

Помогите составить программу на PascalABC.net задание 9.4


image

Информатика (3.5k баллов) | 27 просмотров
Дан 1 ответ
0 голосов

// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50);
  Write('Исходный   : '); a.Println;
  var b:=a.OrderByDescending(t->t).ToArray;
  Write('По убыванию: '); b.Println;
  Write('Остались на месте: ');
  for var i:=0 to a.Length-1 do
    if a[i]=b[i] then Print(a[i]);
end.


image
(142k баллов)