2. Напишите программу формирования и вывода массива размером 6*3, каждые три...

0 голосов
58 просмотров
2. Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по правилу:
1-й – равен значению суммы текущих индексов, увеличенному на 3;
2-й – равен квадрату предыдущего индекса;
3-й – равен сумме двух предыдущих элементов.

Информатика (28 баллов) | 58 просмотров
Дано ответов: 2
0 голосов

Program qq;
var a,b,s:integer;
begin
writeln('Введите число');
readln(a);
b:=a*3;
a:=b*b;
s:=b+a;
writeln('Ответ: ', s);
end.
{На pascal abc проверил работает без ошибок }

(76 баллов)
0

Что-то мало слишком)

0

Сударь вам надо было :1-й – равен значению суммы текущих индексов, увеличенному на 3;
2-й – равен квадрату предыдущего индекса;
3-й – равен сумме двух предыдущих элементов.

0

и вот вам я это сделал :b:=a*3;
a:=b*b;
s:=b+a;

0 голосов

Ответ на задание лежит в файле

(696 баллов)