Написать программу: Попугай Рома вытягивает каждый из семи дней случайным образом число...

0 голосов
46 просмотров

Написать программу:
Попугай Рома вытягивает каждый из семи дней случайным образом число от 1 до 10. Сколько чётных и сколько нечётных чисел он вытянул за неделю.


Информатика (41 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(7,1,10); a.Println;
  var kOdd:=a.Where(t->t.IsOdd).Count;
  Writeln(kOdd,' нечетных, ',7-kOdd,' четных')
end.

Пример
7 2 3 4 2 5 3
4 нечетных, 3 четных
(150k баллов)