Написать программу в Паскале для того чтобы точки попадали в закращенные область Под...

0 голосов
32 просмотров

Написать программу в Паскале для того чтобы точки попадали в закращенные область
Под буквой В
Спасибо заранее


image

Информатика (23 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,y : real;
begin
write('x = '); readln(x);
write('y = '); readln(y);
if (y>=0)and(x*x+y*y<=6*6)and((x<=0)or(x*x+y*y>=3*3))
  then writeln('Да')
  else writeln('Нет')
end.

Пример:
x = 1
y = 2
Нет

(194k баллов)