Язык:С++ Напишите программу, которая сортирует элементы массива по возрастанию последней...

0 голосов
144 просмотров

Язык:С++
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одной строке элементы массива, отсортированного в порядке возрастания последней цифры в десятичной записи чисел, разделив их пробелами. Числа, у которых последняя цифра одинаковая, должны быть выведены в том же порядке, в котором они стояли в исходной последовательности.
Примеры
входные данные
6
219 234 890 81 73 96
выходные данные
890 81 73 234 96 219


Информатика (24 баллов) | 144 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main()
{
    int n;
    cin >> n;
    vector a(n);
    for (int i = 0; i < n; ++i)
        cin >> a[i];
    for (int i = 0; i < n; ++i)
        for (int j = i; j < n; ++j)
            if (a[i]%10 > a[j]%10)
                swap(a[i],a[j]);
    for (int i = 0; i < n;++i)
        cout << a[i] << ' ';<br>
}

(8.8k баллов)