Помогите написать программу, пожалуйста. Напишите программу, которая находит сумму...

0 голосов
29 просмотров

Помогите написать программу, пожалуйста.
Напишите программу, которая находит сумму двухзначных нечетных чисел. Последовательность чисел заканчивается числом 0.


Информатика (29 баллов) | 29 просмотров
0

какой язык?

0

Паскаль

Дано ответов: 2
0 голосов
Правильный ответ

Program n1;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if (a>9) and (a<100) and (a mod 2<>0) then sum:=sum+a;
readln(a);
end;
write(sum);
end.

(149k баллов)
0 голосов
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->t.IsOdd and t.InRange(10,99)).Sum.Println
end.
(150k баллов)