Напишите программу, вычисляющую значение функции [-1 при х<0, у={ 0 при х = 0, 5 при х > 0

0 голосов
116 просмотров

Напишите программу, вычисляющую значение функции [-1 при х<0, у={ 0 при х = 0, 5 при х > 0


Информатика (53 баллов) | 116 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Указывайте пожалуйста ЯП, на котором нужно писать.

Pascal:
program ff;

var
x,y:real;
begin
writeln('Введите x');
readln(x);
if x<0 then y:=-1;<br>if x=0 then y:=0;
if x>0 then y:=5;
writeln(y);
readln();
end.

Python:
print("Введите x")
x = int(input())
if (x<0):<br>    y=-1;
if (x==0):
    y=0;
if (x>0):
    y=5;
print(y)
input()

(292 баллов)