Написать программу ** языке PascalABC, которая умеет выполнять арифметические действия с...

0 голосов
26 просмотров

Написать программу на языке PascalABC, которая умеет выполнять арифметические действия с 5 разными числами и выводит промежуточные и итоговый результаты.

Пример работы программы:

Введите первое число: 4
Выберите первое действие (a) сложить, b) вычесть, c) умножить, d) разделить): a
Введите второе число: 8
Первая операция: 4+8=12
Введите второе действие (a) сложить, b) вычесть, c) умножить, d) разделить): c
Введите третье число: 3
Вторая операция: 12*3=26
.... так до пятого числа и 5 операции


Информатика (462 баллов) | 26 просмотров
0

а как написать такую программу?

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=Arr('первое', 'второе','третье','четвертое','пятое');
  var p,r:real;
  var c:char;
  Write('Введите первое число: '); Readln(r);
  for var i:=0 to 3 do begin
    Write('Выберите ',s[i], ' действие (a) сложить, b) вычесть,');
    Write('c) умножить, d) разделить): '); Readln(c);
    Write('Введите ',s[i+1],' число: '); Readln(p);
    case c of
    'a':r+=p;
    'b':r-=p;
    'c':r*=p;
    'd':r/=p;
      end;
    Writeln('Результат: ',r)
    end
end.

image
(150k баллов)
0

Спасибо огромное!