SOS, нужна помощь!!! Программисты помогите, пожалуйста, написать программу к задаче....

0 голосов
37 просмотров

SOS, нужна помощь!!! Программисты помогите, пожалуйста, написать программу к задаче. Нужно использовать while. Я школьник!


image

Информатика (15 баллов) | 37 просмотров
0

на паскале могу

0

Давай

Дано ответов: 2
0 голосов
Правильный ответ

Var 
   i,                //номер члена последовательности 
   n: integer; //длина последовательности 
   a: double; //заданное число
Begin 
//--------------------------------------Ввод данных----------------------------------------------------
   write('Введите длину последовательности: '); 
   read(n); 
   write('Введите a: '); 
   read(a);
//-----------------------------Вывод последовательности-------------------------------------------
   i:=2;  
   write('Последовательность:  ',1); 
   while i <= n do begin    <br>      write('   ',1+1/i:0:4);           //4 - количество цифр после запятой, если нужна 
                                                  большая точность можно увеличить это число   
      i:=i+1; 
   end; 
   writeln();
//------------------------------Вывод требуемых чисел----------------------------------------------  
   write('Числа меньше а:  '); 
   i:=2; 
   if a > 1 then write(1); 
   while i <= n do begin    <br>      if 1+1/i < a then write('   ',1+1/i:0:4);   //если i-й член последовательности < a,
                                                                                             то печатаем это число 
      i:=i+1;                 //переходим к следующему числу в последовательности
   end;
End.

(688 баллов)
0 голосов
var n: integer;
    a: real;
    arr: array[1..999999] of real;
begin
    write('Введите длину последовательности: ');
    read(n);
    write('Введите a: ');
    read(a);
    for var i := 1 to n do begin
    if i = 1 then
        arr[i] := 1
    else
        arr[i] := 1 + 1/i;
        if arr[i] < a then
        writeln(arr[i]);
    end;
end.
(609 баллов)