Как написать программу для движения окружности(вниз и вправо) в паскале ? помогите...

0 голосов
48 просмотров

Как написать программу для движения окружности(вниз и вправо) в паскале ? помогите пожалуйста


Информатика (16 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Var i:integer;  n,k:real;  begin   n:=10; k:=10;   for i:=1 to 6 do    begin     n:=1.1*n;     k:=k+n;    end;   writeln(k:5:2);  end

(24 баллов)
0

dx:=-1;
dy:=3;
repeat
setcolor(12);
circle(x,y,r);
delay(10);
setcolor(0);
circle(x,y,r);
x:=x+dx;
y:=y+dy;
if x<=x0-d+r+2 then dx:=1<br>else if y>=y0+d-r-2 then dy:=-1
else if x>=x0+d-r-2 then dx:=-1
else if y<=y0-d+r+2 then dy:=1;<br>until keypressed;
end.